“Confluent”的版本间的差异

来自Gea-Suan Lin's Wiki
跳到导航 跳到搜索
設定
安裝
第2行: 第2行:
  
 
== 安裝 ==
 
== 安裝 ==
 +
 +
當然要先裝[[Java]]:
 +
 +
<syntaxhighlight lang="bash">
 +
sudo apt install -y default-jre
 +
</syntaxhighlight>
  
 
 這邊只安裝社群版本:
 
 這邊只安裝社群版本:

2019年3月5日 (二) 20:55的版本

Confluent是一家公司,也是該公司的Apache Kafka產品名。

安裝

當然要先裝Java

sudo apt install -y default-jre

這邊只安裝社群版本:

wget -qO - https://packages.confluent.io/deb/5.1/archive.key | sudo apt-key add -
sudo add-apt-repository "deb [arch=amd64] https://packages.confluent.io/deb/5.1 stable main"
sudo apt install -y confluent-community-2.11

設定ZooKeeper

修改/etc/kafka/zookeeper.properties

#
tickTime=2000
dataDir=/var/lib/zookeeper/
clientPort=2181
initLimit=5
syncLimit=2
server.1=1.2.3.4:2888:3888
server.2=5.6.7.8:2888:3888
server.3=9.10.11.12:2888:3888
autopurge.snapRetainCount=3
autopurge.purgeInterval=24

新增/var/lib/zookeeper/myid,每一台都需要不同,'1''2''3'

'1'

然後修改檔案擁有人:

sudo chown cp-kafka:confluent /var/lib/zookeeper/myid

相關連結

外部連結